Notifications
Clear all

[Sticky] Forum and Website Maintenance this Friday  

Page 3 / 4

Photo Bud
(@photo-bud)
Trusted Member
Joined: 2 years ago
Posts: 95
 

@codecage - 4th and 5th comments in this thread identify the same problem and the temp answer with link. 

This is a recurrence of a problem that was subsequently fixed. It doesn't affect me greatly as I use both Kindle and laptop, but if we have other pad users that are affected without recourse to finding this thread or don't have a computer to request help, we will lose them from the forum.

Photo Bud (aka John)The Old Curmudgeon!


ReplyQuote
codecage
(@codecage)
Member Admin
Joined: 2 years ago
Posts: 1002
 

@photo-bud

OK, I see your reference now, just didn't go back that far.  And that happens to be the link that is in my bookmark.

Not sure how we could actually lose someone just for this issue, because it seems as if they would have to have access to a computer just to have run into an issue they need help with?  Am I missing something here as things in typed messages sometimes lose things from point A to point B?  🤠 

SteveG


ReplyQuote
Photo Bud
(@photo-bud)
Trusted Member
Joined: 2 years ago
Posts: 95
 

@codecage - I just thought it should be brought to attention. It has happened before, reported, and fixed and is now broken again.

Photo Bud (aka John)The Old Curmudgeon!


ReplyQuote
codecage
(@codecage)
Member Admin
Joined: 2 years ago
Posts: 1002
 

@photo-bud

Point taken.

SteveG


ReplyQuote
DroneBot Workshop
(@dronebot-workshop)
Workshop Guru Admin
Joined: 2 years ago
Posts: 939
Topic starter  

@photo-bud when you say "Kindle" I'm assuming you're talking about one of the Kindle Fire Android tablets, and not the Kindle eReader, correct?

And, assuming you are speaking of the tablet, do you experience any difference using it in portrait or landscape mode?  The forum uses a responsive theme so it will redraw itself based upon screen size and orientation.

For the record, I do indeed test the forum and website on a couple of tablets and phones, as well as on several different web browsers on Linux, Mac, and Windows. Right now I only have Android devices, but am considering getting an iPad soon.  And I have found and repaired a number of issues already with mobile platforms.

So I do pay attention to issues with them when I hear about them, as I will with this one.

There is a new version of the forum software that I haven't installed yet, I will schedule a maintenance window soon to do that.  Perhaps it will resolve your issue, especially if you claim that it was previously resolved but reoccurred when the last update was made.  If not then I can investigate it further.

If you could let me know any more information (i.e. android version, browser type) that might be of assistance.

Thanks

😎

Bill

 

"Never trust a computer you can’t throw out a window." — Steve Wozniak


ReplyQuote
Photo Bud
(@photo-bud)
Trusted Member
Joined: 2 years ago
Posts: 95
 

Not an e-reader, Kindle Fire based on Android. Uses Silk browser (their default). First thing I tried was going from portrait (my default) to landscape. What I see on main bar at top is Forums - Members - Recent Posts - Register - Website - YouTube - Help. Nothing in between Register and Website which is where the Login - Logoff tab normally goes.

 

Photo Bud (aka John)The Old Curmudgeon!


ReplyQuote
Photo Bud
(@photo-bud)
Trusted Member
Joined: 2 years ago
Posts: 95
 

Also not showing on the Home, right hand column, only Register.

 

Photo Bud (aka John)The Old Curmudgeon!


ReplyQuote
Photo Bud
(@photo-bud)
Trusted Member
Joined: 2 years ago
Posts: 95
 

Just tried it on my Android phone using Firefox and the same issue on it. Both landscape and portrait.

Edit: On phone, in portrait, the drop down menu (3 bars on left), does NOT show login only Forums - Members - Recent Posts - Register - Website - YouTube.

Photo Bud (aka John)The Old Curmudgeon!


ReplyQuote
DroneBot Workshop
(@dronebot-workshop)
Workshop Guru Admin
Joined: 2 years ago
Posts: 939
Topic starter  

@photo-bud

OK, I see it too on my Android Tablet.

Interestingly, I observed an odd behavior. I didn't have a Login on the menu so I went into a topic and went to the bottom, where it said: "please login or register". I clicked the Login link, and the login box came up. However I didn't login, instead, I closed the box. 

Now login is back on my menu!

I'm going to clean up the forum caches, this should take a few minutes, on the small chance that a style sheet is not refreshing on mobile devices. It should force them to all refresh.

Thanks again for reporting it.

😎

Bill

"Never trust a computer you can’t throw out a window." — Steve Wozniak


ReplyQuote
DroneBot Workshop
(@dronebot-workshop)
Workshop Guru Admin
Joined: 2 years ago
Posts: 939
Topic starter  

Also interesting.

I updated the cache and rebuilt all the user threads, which I don't really think accomplished anything.

While I was waiting for the user threads to rebuild I downloaded Opera onto one of my Android tablets. I went to the forum in landscape mode, and I had no login button.

On portrait mode, I used the "three bar" menu on the side, and there was indeed a Login button.

I didn't login, but went back to landscape mode. And now "Login" is back on my menu.

I need t run away for about an hour, but I have an idea for a "quick fix" if I can't find the actual issue causing this.

 

Thanks

😎

Bill

 

"Never trust a computer you can’t throw out a window." — Steve Wozniak


Photo Bud liked
ReplyQuote
Sid
 Sid
(@sid)
Estimable Member
Joined: 6 months ago
Posts: 127
 
Posted by: @dronebot-workshop

I'm going to clean up the forum caches, this should take a few minutes, on the small chance that a style sheet is not refreshing on mobile devices. It should force them to all refresh.

I think the issue is with some cookies. If you load the site after your cache is cleared off or as I observed in my case it is about change in day/date, I have to reload the page to get the login button and the option on the menu to be visible again.

I have my earlier (clear browser cache on exit) turned off for a while now. But this problem (of not being able to get to the login button at times) still persists.

Posted by: @photo-bud

Just tried it on my Android phone using Firefox and the same issue on it. Both landscape and portrait.

Maybe you too should confirm or at least check on the reloading the page on your handheld device - it might help Bill and Team.

Life is exploring and learning


ReplyQuote
Photo Bud
(@photo-bud)
Trusted Member
Joined: 2 years ago
Posts: 95
 

I just cleared cache on my Kindle and had to login again, with same results.

Photo Bud (aka John)The Old Curmudgeon!


ReplyQuote
Photo Bud
(@photo-bud)
Trusted Member
Joined: 2 years ago
Posts: 95
 

Just cleared cache on phone, restarted Firefox and login/logout now available.

Photo Bud (aka John)The Old Curmudgeon!


ReplyQuote
DroneBot Workshop
(@dronebot-workshop)
Workshop Guru Admin
Joined: 2 years ago
Posts: 939
Topic starter  

I had a thought - did this issue start last week by any chance?

I'm thinking that if it did then the problem is likely the "Help" item I added to the menu. While I did test the individual help screens on the phone and tablet I didn't check the menu.

If that is the issue then please refresh your screens, you may need to clear your caches as well. On the tablet that I just tried it on, once the cache was cleared and the new menu (without Help) was loaded it seemed OK.

See if you are seeing the same thing now, please.

Thanks

😎

Bill

 

"Never trust a computer you can’t throw out a window." — Steve Wozniak


ReplyQuote
DroneBot Workshop
(@dronebot-workshop)
Workshop Guru Admin
Joined: 2 years ago
Posts: 939
Topic starter  

I repeated the experiment on my phone. On initial load, I had no "login" item on the menu, and still had the "help" menu item, so the new menu hadn't loaded.

I refreshed the browser (Chrome on Android) and it was OK, I had the new menu without "help" and login was there.

I'm suspecting that I made the menu too long when I added "help"!

😎

Bill

"Never trust a computer you can’t throw out a window." — Steve Wozniak


ReplyQuote
Page 3 / 4