ROS Jetson Nano RPL...
 

[Solved] ROS Jetson Nano RPLIDAR error message  

  RSS

Chip
 Chip
(@chip)
Trusted Member
Joined: 4 months ago
Posts: 83
2019-12-29 3:57 am  

Just looking for some advice on this error message I am getting when I try running  this in ROS, I have seen others post this same issue and I have not been able to resolve it.

 

lcm@JetsonNano:~/catkin_ws$ roslaunch rplidar_ros view_rplidar.launch
... logging to /home/lcm/.ros/log/c05ee57a-29ed-11ea-b330-fac792b3acb1/roslaunch-JetsonNano-8922.log
Checking log directory for disk usage. This may take awhile.
Press Ctrl-C to interrupt
Done checking log file disk usage. Usage is <1GB.

started roslaunch server  http://192.168.254.73:45251/ 

SUMMARY
========

PARAMETERS
 * /rosdistro: melodic
 * /rosversion: 1.14.3
 * /rplidarNode/angle_compensate: True
 * /rplidarNode/frame_id: laser
 * /rplidarNode/inverted: False
 * /rplidarNode/serial_baudrate: 115200
 * /rplidarNode/serial_port: /dev/ttyUSB0

NODES
  /
    rplidarNode (rplidar_ros/rplidarNode)
    rviz (rviz/rviz)

auto-starting new master
process[master]: started with pid [8935]
ROS_MASTER_URI= http://localhost:11311 

setting /run_id to c05ee57a-29ed-11ea-b330-fac792b3acb1
process[rosout-1]: started with pid [8948]
started core service [/rosout]
process[rplidarNode-2]: started with pid [8951]
process[rviz-3]: started with pid [8961]
[ INFO] [1577591172.617287444]: RPLIDAR running on ROS package rplidar_ros. SDK Version:1.12.0
[ERROR] [1577591172.619556695]: Error, cannot bind to the specified serial port /dev/ttyUSB0.
[rplidarNode-2] process has died [pid 8951, exit code 255, cmd /home/lcm/catkin_ws/devel/lib/rplidar_ros/rplidarNode __name:=rplidarNode __log:=/home/lcm/.ros/log/c05ee57a-29ed-11ea-b330-fac792b3acb1/rplidarNode-2.log].
log file: /home/lcm/.ros/log/c05ee57a-29ed-11ea-b330-fac792b3acb1/rplidarNode-2*.log

This topic was modified 2 months ago by Chip

Quote
Chip
 Chip
(@chip)
Trusted Member
Joined: 4 months ago
Posts: 83
2019-12-29 3:25 pm  

Okay I solved this issue with the command :

sudo usermod -a -G dialout user

and rebooted

 

This post was modified 2 months ago by Chip

ReplyQuote

Please Login or Register