Notifications
Clear all

Programming Seeeduino Xiao with Arduino IDE


sbibat
(@sbibat)
New Member
Joined: 4 weeks ago
Posts: 1
Topic starter  

Hi,

 

I just bought a Seeeduino Xiao and I am trying to upload a sketch using the Arduino IDE, but I'm running into an error when it tries to upload. I'm using the example Blink sketch.

Sometimes when I click upload, it hangs in the "Uploading" phase indefinitely and doesn't upload at all. Other times the microcontroller is trying to access a drive on my computer that doesn't exist. For example, I get the error message "You don't currently have permission to access this folder", on the E: drive, but the E: drive doesn't exist on my computer. My user is an admin, so it's not a permission issue.

 

image
image

 

I've tried hard resetting the Xiao with a jumper wire as well as entering bootloader mode by jumping the reset pads twice (not really sure what bootloader mode does or why I would use it). But the issue still persists after both those troubleshooting steps.

 

For reference, I am using the latest version of the Seeed SAMD Boards, and I am using this URL in the Additional Boards Manager URLs under Preferences, which I got from the Seeeduino Xiao wiki:

https://files.seeedstudio.com/arduino/package_seeeduino_boards_index.json

 

image

 

Has anyone else run into this issue or know how to solve it?

 

Thank you,

Sebastian


Quote
Topic Tags
RCLawn
(@rclawn)
Eminent Member
Joined: 9 months ago
Posts: 47
 

not specifically but have you tried identifying it as an uno or nano? and you might want to check you coms and see if it showing up as seeduino or uno, ect. I had a terrible time with some copy boards.( i had some saying "ramps") they all had to be flashed then they worked. in fact every copy board ive ever bought had to be reprogrammed to work. also you may need to check for a driver, the copy boards had a special one for the the imposter uart chip.

from there ad...Seeeduino V4.2 is an Arduino-compatible board, which is based on ATmega328P MCU, Arduino UNO bootloader, and with an ATMEGA16U2 as a UART-to-USB converter.

 

hope this helps you,

Mike


ReplyQuote
ron bentley
(@ronbentley1)
Estimable Member
Joined: 6 months ago
Posts: 207
 

@sbibat

Hi, yes, I would also suggest selecting a native Arduino board, eg UNO.

If that doesn't work then one has to wonder how compatible this board actually is!

Regards

Ron B

Ron Bentley
Creativity is an input to innovation and change is the output from innovation. Braden Kelley
A computer is a machine for constructing mappings from input to output. Michael Kirby
Through great input you get great output. RZA
Gauss is great but Euler rocks!!


Ron liked
ReplyQuote
Ron
 Ron
(@zander)
Famed Member
Joined: 2 years ago
Posts: 2755
 

@sbibat Bootloader mode is what you must be in in order to do what you are attempting. If you don't have an onboard switch then jumper those pins you mentioned until after the upload is done. As far as being admin, that does NOT prevent that kind of windows error. I stopped using windows in 2017 after 30ish years of it's shenanigans so I am not current enough to help, but I do know I have seen similar errors here and they were all user errors.

It is considered poor judgement to traverse a chasm in 2 leaps.


ReplyQuote
RCLawn
(@rclawn)
Eminent Member
Joined: 9 months ago
Posts: 47
 

How to fix bad Chinese Arduino clones

i think this is the one that solved my problems


ReplyQuote